package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/index(|\.[php|html|htm]\w+)$`)
var str = `/index
/index.html
/index.htm
/index.php
/index.ph`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}