#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[=-]?[0-9]+(\.[0-9]*)?$"
Local $sString = "1231231231231231231" & @CRLF & _
"asdjasdjasd123" & @CRLF & _
"12123123.12312" & @CRLF & _
"1982737.122" & @CRLF & _
"-123.123" & @CRLF & _
"-22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")