const regex = /\q\=\"(.*?)\"/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\q\\=\\"(.*?)\\"', 'gi')
const str = `https://gcom.pdodev.aws.gartner.com/search/research?fc=facetKi:%22Technology%20Market%20Essentials%22&q="at&t"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}