// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\q\=\"(.*?)\""#).unwrap();
let string = "https://gcom.pdodev.aws.gartner.com/search/research?fc=facetKi:%22Technology%20Market%20Essentials%22&q=\"at&t\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}