re = /"[^"]*"|\h+|[^\h"]+/m
str = 'ADD r2, r3[]"ADD[]r2,[]r3"
ADD r2, r3
"ADD r2, r3" "foo bar"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end