package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<mounting_type>Z)(?P<number_of_positions>4)(?P<unit_type>W)(?P<actuation_type>EH)(?P<unit_size>10)(?P<spool_symbol>X181|X183|D24|E68|E63|E51)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/|=)(?P<pilot_valve>4K)(?P<type_of_solenoid>E)(?P<solenoid_in_ac_or_dc_version>G)(?P<voltage_of_solenoid>205|96|24|)(?P<manual_override_unit>N9|)(?P<control_volume_flow>ET)(?P<electrical_connection>K4)(?P<type_of_limit_switch>QM|)(?P<monitored_limit_switch_position>AB|A|B|)(?P<power_supply_of_limit_switch>G24|)(?P<sep_3>/|)(?P<seal_material>V|)(?P<additional_details>(.|[0-9])*)$
`)
var str = `Z4WEH10E63-5X/4KEG24N9ETK4QMAG24
Z4WEH10E68-5X/4KEG24N9ETK4
Z4WEH10E63-5X/4KEG24N9ETK4
Z4WEH10E51-5X/4KEG24N9ETK4
Z4WEH10D24-5X/4KEG24N9ETK4
Z4WEH10X181-5X/4KEG24ETK4
Z4WEH10X183-5X/4KEG24ETK4
Z4WEH10E63-5X/4KEG205ETK4QMAG24
Z4WEH10E63-5X/4KEG24ETK4QMBG24
Z4WEH10E51-5X/4KEG24N9ETK4/V
Z4WEH10E63-5X/4KEG24N9ETK4QMBG24
Z4WEH10E63-5X/4KEG24ETK4QMBG24SO30
Z4WEH10E63-5X/4KEG205N9ETK4
Z4WEH10E68-5X/4KEG24N9ETK4QMAG24
Z4WEH10E68-5X/4KEG24N9ETK4QMBG24
Z4WEH10E63-5X/4KEG24ETK4QMAG24
Z4WEH10E63-5X/4KEG96ETK4QMBG24
Z4WEH10E63-5X/4KEG24N9ETK4QMBG24/V
Z4WEH10E63-5X/4KEG96N9ETK4
Z4WEH10X181-5X/4KEG24ETK4QMBG24
Z4WEH10E63-5X/4KEG96N9ETK4/V
Z4WEH10E63-5X/4KEG24N9ETK4QMAG24/V
Z4WEH10E63-5X/4KEG24N9ETK4/V
Z4WEH10E63-5X/4KEG24ETK4
Z4WEH10E68-5X/4KEG24ETK4QMBG24
Z4WEH10E63-5X/4KEG205ETK4QMBG24
Z4WEH10E63-5X/4KEG24ETK4QLBG24
Z4WEH10E68-5X/4KEG24N9ETK4/V
Z4WEH10E68-5X/4KEG24ETK4QMAG24
Z4WEH10E63-5X=4KEG205N9ETK4
Z4WEH10E51-5X/4KEG24ETK4QMBG24
Z4WEH10E68-5X/4KEG96N9ETK4
Z4WEH10D24-5X/4KEG24ETK4
Z4WEH10E63-5X/4KEG205N9ETK4QMBG24/V
Z4WEH10E63-5X/4KEG96N9ETK4QMBG24
Z4WEH10E63-5X/4KEG96N9ETK4QMBG24/V
Z4WEH10D24-5X/4KEG24ETK4/V
Z4WEH10X183-5X/4KEG24N9ETK4
Z4WEH10E51-5X/4KEG24ETK4SO30
Z4WEH10X183-5X/4KEG24ETK4QMBG24
Z4WEH10E63-5X/4KEG24ETK4QMBG24/V
Z4WEH10E51-5X/4KEG24N9ETK4QMBG24
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}