using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:[^\d>]+|:[A-Za-z0-9]+:)\w+>";
string input = @"<@108012418998792192> (User)
<@!420279649055145996> (User)
<:oof:463391326491377674> (Emote without number in name)
<:Tyler1:311344841466576896> (Emote with number in name)
<:1234:123412314353463456> (Emote that just has number in name)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}