const regex = /^(?!\d*(\d)\1{4})\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d*(\\d)\\1{4})\\d{9}$', 'gm')
const str = `123456789
111156789
111116789
123499999
121314151
322222456
888888888
199999991
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}