$re = '/C:\\\\File Transfer\\\\Relay Files\\\\8Series_files\\\\(?<your_field>[^\\\\]+)\\\\WB_CWP8_869\\\\evt\.txt/m';
$str = 'C:\\File Transfer\\Relay Files\\8Series_files\\WB-CWP\\WB_CWP8_869\\evt.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);