using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Building\D*\b([\d.]+)";
string input = @"Building 38 House 10
Building : 10.5 house 900";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}