package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9][0-9][0-9]{2}-([0][1-9]|[1][0-2])-([1-2][0-9]|[0][1-9]|[3][0-1])`)
var str = `2022-07-11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}