package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:[^:\s]+:|<:[^:\s]+:[0-9]+>|<a:[^:\s]+:[0-9]+>`)
var str = `TEMPLATES
--------------------------------------------------------------
:emote:
<:emote:189855563893571595>
<a:emote:18985556389571595>
OK MESSAGE
--------------------------------------------------------------
:emote:<:emote:189855563893571595><a:emote:189855563893571595>
BAD MESSAGE
--------------------------------------------------------------
:emote::asdf ::emote::: <:hey:>
<:a:emote:> hey
DOES IT WORK?
--------------------------------------------------------------
In the box below (click "Substitution" at the bottom if you can't see it) is all the characters that don't match the regex and will trigger your system to delete the message.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}