re = /[abc]+/
str = 'absdkjfbiqjnovjodf qcnef jqnwdofja oivojcqbjoiebjosfoabbaba
bcbcbabaaasjdcjakjdbcbbcbcasajhdfabcbcc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end