use strict;
my $str = 'pos Désignation article
articles N° d\'origine
Fabricant Prix net H.T
commandé(e)
livré(s) remise Texte de la commande Prix
mise au rebut
1
PLATINE, AUDIO RECORDER
F192103 996510063444
GIBSON/PHILIPS € 25,17
2
2 0 %
€ 0,00 S0630500245392 P000767686 € 55,34
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
2
ASSY-MAIN BOARD HTL316
G922573 996580008736
GIBSON/PHILIPS € 12,80
3
3 0 %
€ 0,00 S0630005248395 P000567585 € 38,40
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
3
3300UF25V CHIMI. RADI 105GRAD6X25
3369044
€ 0,65
20
20 0 %
€ 0,00 S0630005548392 P005767586 € 13,00
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
4
MOTOR DC <=37.5W
F629401 996580001916
GIBSON/PHILIPS € 7,71
1
0 0 %
€ 0,00 S0630000548352 P005765686 € 0,00
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
cet article vous parviendra ultérieurement dans u colis séparé
5
MECH. UNIT, DVD PLAYER
F192078 996510059018
GIBSON/PHILIPS € 9,95
1
1 0 %
€ 0,00 S0630000548392 P005767686 € 9,95
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
6
MECANIQUE DVD
F192541 996510066471
GIBSON/PHILIPS € 18,50
19
19 0 %
€ 0,00 S0630000255392 P000765686 € 351,50
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
7
MAIN+DC+USB+WIFI SOCKE
G813754 996580007956
GIBSON/PHILIPS € 79,25
1
0 0 %
€ 0,00 S0630000248352 P000757686 € 0,00
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
8
BROSSE COMBINÉ
G787239 140030390060
ELECTROLUX € 29,77
1
1 15 %
€ 4,47 R002788521 P000755686 € 25,30
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
9
ACCU 22,2V
D436440 91708307
DYSON € 29,75
1
1 15 %
€ 4,46 R002756551 P000767686 € 25,29
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
10
RESSORT DE CUVE
G958435 43011062
GROUPE CANDY € 4,50
1
1 15 %
€ 0,68 R002792326 P000767686 261177 € 3,82
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
11
REGENERATION UNIT
D18109 1741600500
€ 6,95
1
1 20 %
€ 1,39 R002788169 P000767686 11872 € 5,56
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
12
POMPE DE VIDANGE ASKOLL 6353334W
5878082 91200173
GROUPE CANDY € 22,75
1
1 15 %
€ 3,41 R002788982 P000767686 11913 € 19,34
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
13
PRESSOSTAT
Y53031 DC9601703B
SAMSUNG € 22,95
1
1 0 %
€ 0,00 R002789006 P000767686 12156 € 22,95
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
14
016912 RÉSISTANCE DE SOLE 1300W FAGORCA50042A9
F289696
€ 22,35
1
1 0 %
€ 0,00 R002789196 P000767686 11966 € 22,35
€ 0,00 ouvre la page détaillée de l\'article avec la quantité commandée et les références par position
total
Vous avez commandé 14 articles au prix de € 555,55
Frais de recyclage € 0,00
Frais de port € 0,00
20,00 % TVA € 555,55
Montant de la facture € 555,55
Vue avant impression';
my $regex = qr/(?m)\d+\t\v\s\v.+\v(.+)\t(.+)\s\v(.+)\s€\s\d+,\d+\v\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}