package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Link:\h*(\S+)\h+Password:\h*(\S+)`)
var str = `Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}