const regex = /Link:\h*(\S+)\h+Password:\h*(\S+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Link:\\h*(\\S+)\\h+Password:\\h*(\\S+)', 'gmu')
const str = `Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}