// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?mu)Link:\h*(\S+)\h+Password:\h*(\S+)").unwrap();
  let string = "Link:https://pan.baidu.com/s/1aKsPhvckPRB2RGheB9KW5g Password:vvbd
";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}