#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[“”](?=[^\]\[]*\])"
Local $sString = "“foobar” [tagname id=“1035” linked=“true”] “another” [tagname id=“1”]"
Local $sSubst = """
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)