package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"[^\"]+\"\s*:\s*(\")`)
var str = `{ "data": [ { "abc": "xyz: " } ] }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}