import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*data_augmentation_options[\\s\\S]+(?=^[ \\t]*data_augmentation_options)";
final String string = " batch_size: 4\n"
+ " num_steps: 30\n"
+ " data_augmentation_options {\n"
+ " random_horizontal_flip {\n"
+ " keypoint_flip_permutation: 0\n"
+ " keypoint_flip_permutation: 2\n"
+ " keypoint_flip_permutation: 1\n"
+ " keypoint_flip_permutation: 4\n"
+ " keypoint_flip_permutation: 3\n"
+ " keypoint_flip_permutation: 6\n"
+ " keypoint_flip_permutation: 5\n"
+ " keypoint_flip_permutation: 8\n"
+ " keypoint_flip_permutation: 7\n"
+ " keypoint_flip_permutation: 10\n"
+ " keypoint_flip_permutation: 9\n"
+ " keypoint_flip_permutation: 12\n"
+ " keypoint_flip_permutation: 11\n"
+ " keypoint_flip_permutation: 14\n"
+ " keypoint_flip_permutation: 13\n"
+ " keypoint_flip_permutation: 16\n"
+ " keypoint_flip_permutation: 15\n"
+ " }\n"
+ " }\n\n"
+ " data_augmentation_options {\n"
+ " random_crop_image {\n"
+ " min_aspect_ratio: 0.5\n"
+ " max_aspect_ratio: 1.7\n"
+ " random_coef: 0.25\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}