#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)HEADLINE(?:(?!HEADLINE)[\s\S])*(?<!NON-)ARC(?:(?!HEADLINE)[\s\S])*"
Local $sString = "HEADLINE" & @CRLF & _
"Subheader Author" & @CRLF & _
"NON-ARC 0.1-1" & @CRLF & _
"20190211" & @CRLF & _
"" & @CRLF & _
"HEADLINE" & @CRLF & _
"Subheader Author" & @CRLF & _
"ARC 0.1-1" & @CRLF & _
"20190211" & @CRLF & _
"" & @CRLF & _
"HEADLINE" & @CRLF & _
"Subheader Author" & @CRLF & _
"NON-ARC 0.1-1" & @CRLF & _
"20190211" & @CRLF & _
"" & @CRLF & _
"HEADLINE" & @CRLF & _
"Subheader Author" & @CRLF & _
"20190211" & @CRLF & _
"" & @CRLF & _
"HEADLINE" & @CRLF & _
"Subheader Author" & @CRLF & _
"ARC 0.1-1" & @CRLF & _
"20190211"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")