package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id"\s*:\s*"([\w=]*)"`)
var str = `{
"wallets" : [ {
"id" : "eyJpZGVudGl0eSI6WzQ4LDQyLDQ4LDUsNiwzLDQzLDEwMSwxMTIsMywzMywwLC0zMCw4MSwxMDQsMCw2NywtMTcsNDcsLTM0LC0yNiwtNDksLTg0LDkxLC0xMDgsMTcsMjUsMTksLTcxLC0xMTcsLTEwMywzNSwtMjEsNDAsLTcyLDY3LDEwNSwxMCwtNDAsMTE3LC0xMTEsLTEwLDExNiwtNThdLCJ2ZXJzaW9uIjoiMC4xLjEifQ=="
} ]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}