package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|[12][0-9]|3[01])\/(0[1-9]|1[0-2])\/([0-9]{4})$`)
var str = `01/01/2025
13/09/2025
2025/09/09
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}