re = /^(0[1-9]|[12][0-9]|3[01])\/(0[1-9]|1[0-2])\/([0-9]{4})$/m
str = '01/01/2025
13/09/2025
2025/09/09
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end