using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"")(Level\s\d+)(?!"")";
string input = @"This is a test with various ""Level 2"" and Level 5 and stuff.
Not sure how to treat ""Level 2 or Level 5"" though.
Also capturing Level 12 would be nice I guess? (Not ""Level 12"" of course though)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}