use strict;
my $str = 'This is a test with various "Level 2" and Level 5 and stuff.
Not sure how to treat "Level 2 or Level 5" though.
Also capturing Level 12 would be nice I guess? (Not "Level 12" of course though)
';
my $regex = qr/(?<!")(Level\s\d+)(?!")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}