use strict;
my $str = 'Available operations.
1. 2+3
2. 2-3
3. 2*3
4. 2/3
5. 2^3
Negative numbers.
6. -2+3
7. 2+-3
8. -2+-3
9. -2--3
Ignores spaces, but not zeroes
10. 2 + 3
11. 15 ^ -1
12. -00+ 02';
my $regex = qr/(?<lhs>(?:[\+\-]*)?\d+) *(?<op>[\+\-\*\/\^]) *(?<rhs>(?:[\+\-] *)?\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}