import Foundation
let pattern = #"(?<lhs>(?:[\+\-]*)?\d+) *(?<op>[\+\-\*\/\^]) *(?<rhs>(?:[\+\-] *)?\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Available operations.
1. 2+3
2. 2-3
3. 2*3
4. 2/3
5. 2^3
Negative numbers.
6. -2+3
7. 2+-3
8. -2+-3
9. -2--3
Ignores spaces, but not zeroes
10. 2 + 3
11. 15 ^ -1
12. -00+ 02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)