import Foundation
let pattern = #"([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
    位: {
      default: '左',
      type: String,
    },
    高: {
      default: '',
      type: [String, Number],
    },
    宽: {
      default: '',
      type: [String, Number],
    },
    驼高: {
      default: '',
      type: String,
    },
    骆高: {
      default: '',
      type: String,
    },
    样: {
      default: '工 gong',
      type: String,
    },
    料: {
      default: () => {
        return []
      },
      type: Array,
    },
    啥: {
      defaule: () => {
        return {}
      },
      type: Object,
    },
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6$7\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)