// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?\:\/\/)?[\w.]+").unwrap();
let string = "https://site.ru
http://site.ru
http://site.xyz/bla
https://site.com/blabla/test
https://en.site.com/blabla/test
site.ru/blabla/test/test2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}