#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<!\S)(?:https?:\/\/)?(?:(?:(?!example)\w+[.-])+[a-z]{2,11})(?!\S)"
Local $sString = "name.url.com name-dev.url.com name-qa.url.com www.example.com test.example.com http://NewMediaFilmFestival.com http://www.test.com https://www.example.com jfsalkjflkdjfa.vuulr.com" & @CRLF & _
"jfsalkjflkdjfa.com" & @CRLF & _
""
Local $sSubst = "[URl Hidden]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)