re = /http(.*?).(jpg|png|gif|webp|jpeg)/mi
str = 'https://gitee.com/artiely/Figure-bed/raw/master/20220123084210.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end