re = /this(?(_star)\s*|)(?P<_star>[\w\s]{,10}?)?(?(_star)\s*|)(?(_star2)\s*|)(?P<_star2>[\w\s]{10,})?(?(_star2)\s*|)ok$/m
str = 'this is great hyes jljladsf dsaf ljaldsjlfjoiuajdsflj ok
this is (\\w+\\s+)?(?(1)\\s|\\w)
this *
*10
*1,2
*2
*2,10
*,10
(?(_star)\\s*|)(?P<_star>[\\w\\s]{10}?)?(?(_star)\\s*|)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end