import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s*:\\s*((?:(?!\\s*\\w+\\s*:).)*)";
final String string = "field1 : value1a value1b\n\n"
+ "field1 : value1a value1b field2 : value2a value2b\n\n"
+ "field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}