const regex = /(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s*:\\s*((?:(?!\\s*\\w+\\s*:).)*)', 'gm')
const str = `field1 : value1a value1b
field1 : value1a value1b field2 : value2a value2b
field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}