re = /(\w+)\s*:\s*((?:(?!\s*\w+\s*:).)*)/m
str = 'field1 : value1a value1b
field1 : value1a value1b field2 : value2a value2b
field1 : value1a field2 : value2a value2b field3 : value3a value3b value3c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end