# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\s*)(.+)((?<=\w)\s*$)/\U\2/gm;t' <<< " Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
Real Economic Impact for Careful àssessment
real "