# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n\s+Security ID:[^\n]+\n\s+Account Name:\s+(?<accounts>[^\n]+)"
test_str = ("6/6/19\n"
"9:27:22.000 AM \n"
"06/06/2019 09:27:22 AM\n"
"LogName=Security\n"
"SourceName=Microsoft Windows security auditing.\n"
"EventCode=4720\n"
"EventType=0\n"
"Type=Information\n"
"ComputerName=CPMASNAAD03.na.cintas.com\n"
"TaskCategory=User Account Management\n"
"OpCode=Info\n"
"RecordNumber=5472484169\n"
"Keywords=Audit Success\n"
"Message=A user account was created.\n\n"
"Subject:\n"
" Security ID: \"xxxxxxxxx\"\n"
" Account Name: Account Creator\n"
" Account Domain: xxxxx\n"
" Logon ID: xxxxxxx\n\n"
"New Account:\n"
" Security ID: \"xxxxxx\"\n"
" Account Name: Account Created\n"
" Account Domain: xxxxxxx\n\n"
"Attributes:\n"
" SAM Account Name: xxxxxxxx\n"
" Display Name: User\n"
" User Principal Name: -\n"
" Home Directory: -\n"
" Home Drive: -\n"
" Script Path: -\n"
" Profile Path: -\n"
" User Workstations: -\n"
" Password Last Set: <never>\n"
" Account Expires: <never>\n"
" Primary Group ID: 513\n"
" Allowed To Delegate To: -\n"
" Old UAC Value: 0x0\n"
" New UAC Value: 0x11\n"
" User Account Control: \n"
" Account Disabled\n"
" 'Normal Account' - Enabled\n"
" User Parameters: -\n"
" SID History: -\n"
" Logon Hours: <value not set>\n\n"
"Additional Information:\n"
" Privileges")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.