import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\d{1,2}(?!\\d)";
final String string = "This expression finds 1 or 2 digits that are not enclosed with any other digit, so it will find a match in `a12b`, `1`, `12`, `a_1_b`, `x_23` strings.\n\n"
+ "123\n"
+ "1233333";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}