re = /^\+(?<PHONENUMBER>\d{8,15})$/m
str = '+12345678
+1234567
+123456
+12345
+16157725198
+16157725198
+111111111111111
+1111111111111111
+1111111111111111123123123123123213123
+1(801)8221439
+1(801) 822 1439
+1-801-822-1439'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end