re = />([^<]+)<\/span><\/a><\/div><div class=\"aahdfvyu\">/m
str = 'b282yb keod5gw0 nxhoafnm aigsh9s9 d3f4x2em iv3no6db jq4qci2q a3bd9o3v lrazzd5p bwm1u5wc" dir="auto"><span class="a8c37x1j ni8dbmo4 stjgntxs l9j0dhe7 ltmttdrg g0qnabr5">Text #1</span></a></div><div class="aahdfvyu"></span></span></div></div><div class="n00jemau55g9w c8b282yb keod5gw0 nxhoafnm aigsh9s9 d3f4x2em mdeji52x a5q79mjw g1cxx5fr lrazzd5p oo9gr5id" dir="auto">Text #2</span></a></div><div class="aahdfvyu"><span class="d2edcug0 hpfvmrgz qv66sw1b c1e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end