$re = '/^([A-Z]{2,}\!?) ([^(]+)(?<!\s) ?(?<BR>\()?((?(BR)[^\)]+))(?(BR)(\)))$/m';
$str = 'PREFIX description goes here (optional)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);