const regex = /\b(?:I|US|TX)-\d{1,3} \w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:I|US|TX)-\\d{1,3} \\w+', 'gm')
const str = `I-35 South / US-290 West`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}