re = /blog\/tag\//m
str = 'https://shmoo.pie/blog/tag/tom
https://shmoo.pie/blog/tag/yaron'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end