#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*10[Bb]it)(.*[x|h]\.?(265|HEVC).*)$"
Local $sString = "Thor The Dark World 2013 Bluray 2160p x265 10Bit HDR TrueHD Atmos 7.1 mUHD -iCandy" & @CRLF & _
"something.without.8bit.whoknows" & @CRLF & _
"Something.just.with.h265.hvec in.it" & @CRLF & _
"Thor.The.Dark.World.2013.PROPER.1080p.UHD.BluRay.DD+7.1.x264-LoRD" & @CRLF & _
"Thor.The.Dark.World.2013.2160p.UHD.HDR10.BluRay.Multi.TrueHD.7.1.x265-4K4U" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")