#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\b401\b)(?=.*?\be?30(?:th|st)?\b).*"
Local $sString = "401 300th st" & @CRLF & _
"40120 30 street" & @CRLF & _
"30 401 plz" & @CRLF & _
"401 30th st" & @CRLF & _
"401 e gibbsborro rd, 305" & @CRLF & _
"401 e 30th street, shelter" & @CRLF & _
"401 east 30st" & @CRLF & _
"401 e30th street, 3" & @CRLF & _
"77-02 30th ave, 3rd fl" & @CRLF & _
"401 e30 st." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")