const regex = /^(?=.*\b401\b)(?=.*?\be?30(?:th|st)?\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\b401\\b)(?=.*?\\be?30(?:th|st)?\\b).*', 'gm')
const str = `401 300th st
40120 30 street
30 401 plz
401 30th st
401 e gibbsborro rd, 305
401 e 30th street, shelter
401 east 30st
401 e30th street, 3
77-02 30th ave, 3rd fl
401 e30 st.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}