import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+";
final String string = "Tsuru Stork greeting for a long last life. Unisex\n"
+ "Yama Mountain; Restrainer; Unisex \n"
+ "Yuka A bright Star Unisex \n"
+ "Yumi A beautiful archery bow Unisex \n"
+ "Yuna The archer Unisex";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}