$re = '/^testing_v(?P<sm>[0-9\.]+([\-][0-9]+)?)?(\_[0-9A-Za-z-]+)?$/m';
$str = 'testing_v14.8.1-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);