$re = '/https:\/\/(?:web.archive.org\/web\/\d*(?:|if_)|archive.*\/.*\/)\/((?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n?]+)).*$/m';
$str = 'https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
https://archive.ph/2021.07.09-181138/https://www.dominio.net/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);